Glipper crashed with ValueError in load()

I found out that klipper is not working well in Ubuntu 11.10 version. I installed glipper in my machine and after a reboot, met with this error.

glipper crashed with ValueError in load(): invalid literal for int() with base 10: “\xcb#W\x84\xb0\x0e […] \r”

The workaround appears to be to just forget about the invalid history file (or move it away):

$ rm ~/.local/share/glipper/history

geo@ubuntu:~$ ll .local/share/glipper/history
-rw-rw-r– 1 geo geo 27041 2012-02-16 10:28 .local/share/glipper/history
geo@ubuntu:~$ rm -f .local/share/glipper/history

geo@ubuntu:~$ glipper &
[1] 7221
geo@ubuntu:~$ SHARED_DATA_DIR: /usr/share/glipper
Binding shortcut c to popup glipper
Changed process name to: glipper

Glipper started working again…