EasyApache Internal Server Error

If Easy Apache gives Internal Server Error like this,

“Internal Server Error

Premature end of script headers: /usr/local/cpanel/whostmgr/docroot/cgi/easyapache.pl: Please check / usr / local / cpanel / logs / error_log for the exact error.”

By following the breadcrumbs(i.e. the error message) and checking the error_log, I find that the problem is:

Acme::Spork version v0.0.8 required–this is only version v0.0.7 at /var/cpanel
/perl/easy/Cpanel/Easy/Utils/BackGround.pm line 14.
BEGIN failed–compilation aborted at /var/cpanel/perl/easy/Cpanel/Easy/Utils/Bac
kGround.pm line 14.
Compilation failed in require at (eval 28) line 3.
…propagated at /usr/lib/perl5/5.8.8/base.pm line 85.
at (eval 26) line 3
at /var/cpanel/perl/easy/Cpanel/Easy.pm line 15
BEGIN failed–compilation aborted at /var/cpanel/perl/easy/Cpanel/Easy.pm line 1
5.
Compilation failed in require at (eval 16) line 3.
…propagated at /usr/lib/perl5/5.8.8/base.pm line 85.
BEGIN failed–compilation aborted at /var/cpanel/perl/easy/Cpanel/Easy/Apache.pm
line 8.
Compilation failed in require at /usr/local/cpanel/whostmgr/docroot/cgi/easyapac
he.pl line 67.”

Download and install latest Acme::Spork module in the server (now v0.0.8), it will fix the error.

Leave a Reply

Your email address will not be published. Required fields are marked *